mirror of
https://github.com/starr-dusT/dotfiles.git
synced 2025-02-19 19:27:31 -08:00
69 lines
2.2 KiB
Nix
69 lines
2.2 KiB
Nix
# Do not modify this file! It was generated by ‘nixos-generate-config’
|
||
# and may be overwritten by future invocations. Please make changes
|
||
# to /etc/nixos/configuration.nix instead.
|
||
{ config, lib, pkgs, modulesPath, ... }:
|
||
|
||
{
|
||
imports =
|
||
[ (modulesPath + "/installer/scan/not-detected.nix")
|
||
];
|
||
|
||
boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "usb_storage" "usbhid" "sd_mod" "sr_mod" ];
|
||
boot.initrd.kernelModules = [ ];
|
||
boot.kernelModules = [ "kvm-intel" ];
|
||
boot.extraModulePackages = [ ];
|
||
|
||
fileSystems."/" =
|
||
{ device = "/dev/disk/by-uuid/fbbf0ca2-4f05-48ff-b341-7da2895260cc";
|
||
fsType = "btrfs";
|
||
options = [ "subvol=root" ];
|
||
};
|
||
|
||
fileSystems."/engi" =
|
||
{ device = "/dev/disk/by-uuid/535012d6-71c2-40e3-85a5-71bb2e971ad0";
|
||
fsType = "btrfs";
|
||
};
|
||
|
||
fileSystems."/home" =
|
||
{ device = "/dev/disk/by-uuid/fbbf0ca2-4f05-48ff-b341-7da2895260cc";
|
||
fsType = "btrfs";
|
||
options = [ "subvol=home" ];
|
||
};
|
||
|
||
fileSystems."/nix" =
|
||
{ device = "/dev/disk/by-uuid/fbbf0ca2-4f05-48ff-b341-7da2895260cc";
|
||
fsType = "btrfs";
|
||
options = [ "subvol=nix" ];
|
||
};
|
||
|
||
fileSystems."/persist" =
|
||
{ device = "/dev/disk/by-uuid/fbbf0ca2-4f05-48ff-b341-7da2895260cc";
|
||
fsType = "btrfs";
|
||
options = [ "subvol=persist" ];
|
||
};
|
||
|
||
fileSystems."/var/log" =
|
||
{ device = "/dev/disk/by-uuid/fbbf0ca2-4f05-48ff-b341-7da2895260cc";
|
||
fsType = "btrfs";
|
||
options = [ "subvol=var/log" ];
|
||
};
|
||
|
||
fileSystems."/boot" =
|
||
{ device = "/dev/disk/by-uuid/C42C-A103";
|
||
fsType = "vfat";
|
||
};
|
||
|
||
swapDevices = [ ];
|
||
|
||
# Enables DHCP on each ethernet and wireless interface. In case of scripted networking
|
||
# (the default) this is the recommended approach. When using systemd-networkd it's
|
||
# still possible to use this option, but it's recommended to use it in conjunction
|
||
# with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
|
||
networking.useDHCP = lib.mkDefault true;
|
||
# networking.interfaces.enp4s0.useDHCP = lib.mkDefault true;
|
||
|
||
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
|
||
powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
|
||
hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
|
||
}
|